Delayed exports
Incident Report for Nutshell
Resolved
We've added capacity and all delayed exports have been completed. Sorry for the trouble!
Posted 17 days ago. Feb 08, 2018 - 11:27 EST
Identified
We've identified an issue with exporting to spreadsheets. We're working on a fix now!
Posted 17 days ago. Feb 08, 2018 - 10:47 EST