Data imports in the web app may not finish
Incident Report for Nutshell
Resolved
We have identified the cause of import issues, and all imports should complete successfully at this point.
Posted 4 months ago. Jun 27, 2017 - 14:59 EDT
Investigating
We are investigating an issue on our backend affecting data imports submitted via the web app. We will update this page with more information as it becomes available.
Posted 4 months ago. Jun 27, 2017 - 09:10 EDT