Degraded service
Incident Report for Nutshell
Resolved
We have addressed the cause of the performance issue, and Nutshell should be back to normal operation.
Posted 5 months ago. May 19, 2017 - 16:38 EDT
Investigating
We have identified an issue with our back end servers that are causing some slow user experience in Nutshell. We are investigating potential causes, and are working to return to normal service.
Posted 5 months ago. May 19, 2017 - 16:01 EDT