Billing page issues
Incident Report for Nutshell
Resolved
This incident has been resolved.
Posted 4 months ago. Feb 06, 2019 - 18:49 EST
Monitoring
The billing page is fully operational again, and we will continue to monitor.
Posted 4 months ago. Feb 06, 2019 - 16:24 EST
Identified
An issue has been identified with our billing page. It should be resolved shortly, but in the meantime, if you need immediate changes to your billing information, please contact our customer experience team directly. They can be reached at 888-336-8808, from 9 to 4 EST.
Posted 4 months ago. Feb 06, 2019 - 15:35 EST
This incident affected: Billing.