Intermittent outages for some customers
Incident Report for Nutshell
Resolved
This incident has been resolved.
Posted over 1 year ago. Aug 01, 2016 - 23:38 EDT
Investigating
We are currently investigating this issue.
Posted over 1 year ago. Aug 01, 2016 - 23:12 EDT