Slow load times for app.nutshell.com
Incident Report for Nutshell
Resolved
This incident has been resolved.
Posted 11 months ago. Dec 05, 2016 - 10:17 EST
Update
Load times should be back to normal.
Posted 11 months ago. Dec 05, 2016 - 08:58 EST
Investigating
Nutshell is currently experiencing slower-than-normal load times. We are currently investigating the issue.
Posted 11 months ago. Dec 05, 2016 - 08:44 EST