Nutshell Marketing outage

Incident Report for Nutshell

Resolved

This incident has been resolved.
Posted Nov 30, 2021 - 14:41 EST

Investigating

Outgoing emails sent with Nutshell Marketing are currently not being delivered. We're working to resolve this issue as quickly as possible and will provide updates as soon as we have them! Thank you for your patience.
Posted Nov 26, 2021 - 13:07 EST
This incident affected: Nutshell Marketing outgoing email.