Nutshell outage

Incident Report for Nutshell

Resolved

Nutshell has been performing at optimal levels for several hours. We continue to monitor for any issues that might result from our infrastructure provider. Our team will perform a retrospective to identify ways to mitigate future issues and learn from this experience. No data was lost during this event.
Posted Oct 20, 2025 - 17:29 EDT

Monitoring

We have deployed additional resources and Nutshell is now performing quickly. We are continuing to monitor issues from AWS that may impact Nutshell availability.
Posted Oct 20, 2025 - 12:04 EDT

Identified

As of 10:50am, Nutshell is running slower than expected. We are currently working with AWS to add more resources.
Posted Oct 20, 2025 - 10:53 EDT

Monitoring

At approximately 7:15 ET, Nutshell performance began to decline until the app was unavailable. Our team identified an issue with AWS, our infrastructure provider. As of 8:20am, we completed a configuration change to work around the identified problems. Nutshell is currently up and running, and we are monitoring further developments from AWS.
Posted Oct 20, 2025 - 08:30 EDT
This incident affected: Nutshell application.