App performance and access issues

Incident Report for Nutshell

Resolved

This incident has been resolved.
Posted Mar 27, 2025 - 13:13 EDT

Monitoring

A fix has been released, and normal Nutshell operation has been restored to all customers.
Posted Mar 27, 2025 - 12:54 EDT

Identified

Nutshell is unavailable to many customers - our team has identified the issue and is implementing a fix. We expect a resolution in the next 15 minutes.
Posted Mar 27, 2025 - 12:33 EDT

Investigating

Customers are experiencing slow load times and frequent errors in Nutshell, our team is actively investigating.
Posted Mar 27, 2025 - 12:25 EDT
This incident affected: Nutshell application.