Slowdown & delays for some customers

Incident Report for Nutshell

Resolved

We have addressed the database issue which caused some slowdowns for our customers. We are continuing to expand our infrastructure fleet for a more reliable and speedy Nutshell experience!
Posted Jun 04, 2026 - 13:16 EDT

Identified

We have identified an issue in one of our database clusters which is causing slowdowns for approximately 20% of our customers. Nutshell should now be accessible, but there may be some delays in updates to lists and searching.
Posted Jun 04, 2026 - 12:45 EDT
This incident affected: Nutshell application.